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Abstract 
Water has existed in an unchanging state since the beginning of time, when it originally appeared. Little has 
been taken away or added over the years. Between the oceans, atmosphere, cryosphere, and the land, water 
is always moving. The hydrologic cycle is the exchange of water between reservoirs in the ocean, atmosphere, 
and land. Concerns exist regarding the quality of available water resources. Human health and happiness are 
intimately related to the quality of the water consumed, and water consumption per capita is a good indicator 
of peoples' quality of life as well as their economic and social standing. More than half of the world's 
population is predicted to be vulnerable to water by the year 2025. The preset study is aimed to is to use the 
GIS for analysis of rainfall in district Jhunjhunu. 
 
Introduction: 
 
The oceans hold around 96.5% of the water on Earth, which covers about 71 percent of its surface. Water also 
resides in the ground as soil moisture and in aquifers, in the air as water vapour, in rivers, lakes, icecaps, and 
glaciers, as well as inside of you and your dog. Water is constantly moving. The source of water is continually 
shifting from one location and one form to another. 96.54% of the world's water resources are salt water, 
mostly found in the oceans, with the remaining 4% being fresh water. Groundwater makes up 1.69% of 
freshwater, ground ice and permafrost make up 0.022% of it, lakes make up 0.013%, while the atmosphere 
only makes up 0.001% of it.  
 
Water is a naturally occurring resource that is essential to all living things. A sufficient, safe, and easily 
accessible supply of water must be supplied to everyone as it is necessary for maintaining life. Water makes 
up 60% of the human body and 90% of a plant's body, respectively. In this sense, water resources have been 
viewed as important reserves, and infrastructure-developing nations have also made an effort to comprehend 
these resources' potential. Nearly everywhere in the world, groundwater is crucial for human consumption, 
habitat support, and base-flow maintenance of rivers. They are often clear, colourless, and free of 
microbiological contamination because they were naturally filtered throughout their transit through the 
ground and only need minor treatment.   
 
Methodology: 
 
QGIS (formerly Quantum GIS) is an open-source geographic information system (GIS). This software is a free 
alternative to proprietary GIS software such as ESRI’s ArcGIS products which can be very expensive. QGIS 
incorporates similar functions and features as its proprietary counterparts and allows users to display, 
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manipulate and create spatial data. The QGIS is open source and very simple software. There are two simple 
ways to import the point data into QGIS, depending on the type of data like shapefile, CSV file, excel 
spreadsheet. 
 

 
 

SHAPEFILE DATA 
  
A shapefile is a simple, nontopological format for storing the geometric location and attribute information of 
geographic features. Geographic features in a shapefile can be represented by points, lines, or polygons 
(areas). The workspace containing shapefiles may also contain dBase tables, which can store additional 
attributes that can be joined to a shapefile's features. To import a shape file, click on the ‘Layer’ tab in the 
upper left hand corner of the screen, and select the ‘Add Vector Data’ tab.  A window will then prompt you to 
navigate to your saved shape file dataset on your hard drive. Afterwards click ‘open’ and you should see your 
point data on the main display. 

 

 
 
EXCEL SHEET DATA 
 
Spreadsheets are composed of columns and rows that create a grid of cells. Typically, each cell holds a single 
item of data. Here's an explanation of the three types of data most commonly used in spreadsheet 
programs:  
1. Text data, also called labels, is used for worksheet headings and names that identify columns of data.  
2. Number data, also called values, is used in calculations. By default, numbers are right aligned in a cell. 

In addition to actual numbers, Excel also stores dates and times as numbers 
3. Formulas are mathematical equations that work in combination with data from other cells on the 

spreadsheet. Simple formulas are used to add or subtract numbers. Advanced formulas perform 
algebraic equations.  
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If the data for QGIS is in the form of an Excel spreadsheet, where the points have associated latitudes, 
longitudes and attribute data, we have to save it as a comma-separated value (CSV) file before trying to import 
it into QGIS. To import a CSV file, click on the ‘Layer’ tab in the upper left hand corner of the screen, and select 
the ‘Add Delimited Text Layer’ tab.  
 

 
 
A window will then prompt you to navigate to your saved CSV file on your hard drive. Assign a layer name for 
the output point data. Select the ‘longitude’ field to represent the x-values and the ‘latitude’ field to represent 
the y-values. You may be also prompted to provide a map projection for the data (sometimes this is done 
automatically). If so, select the appropriate geographic coordinate system for your dataset. Then click ‘ok’ to 
load the x and y point data.  
 

 
 
The next step when loading a CSV file is exporting the loaded point data (from the previous step) to a shapefile. 
To do this in QGIS, right-click on the loaded point data layer and click the ‘Export > Save features as’ tab. 
A window will then prompt you to pick the format of the file being saved, choose ‘ESRI Shapefile’. Browse for 
a location to save the shapefile on your hard drive and assign the filename for the output shapefile.  
You will also need to specify a projected coordinate system for the output shapefile, in order to run 
interpolations on it in later steps. And lastly, check the ‘Add saved file to map’ box. Then click ‘ok’. 
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Creating the IDW Interpolated Raster Surfaces  
 
Interpolation is a commonly used GIS technique to create a continuous surface from discrete points. A lot of 
real-world phenomena are continuous – rainfall, elevations, soils, temperatures etc. If we wanted to model 
these surfaces for analysis, it is impossible to take measurements throughout the surface. Hence, the field 
measurements are taken at various points along the surface and the intermediate values are inferred by a 
process called ‘interpolation’. In QGIS, interpolation is achieved using the built-in Interpolation tools from the 
Processing toolbox. 
 

 
 
The interpolation method that will be used in the project is the IDW interpolation. Click on the ‘Processing’ 
tab and select ‘Toolbox’. The ‘Processing Toolbox’ panel will then appear on the right side of the map view. 
You will notice that QGIS draws tools from 8 different GIS sources including its own QGIS tool selection. The 
easiest way to find an appropriate interpolation tool is to type ‘Interpolation’ into the upper search column. 
Now choose Inverse Distance Power Interpolation and double click on the IDW Interpolation. The IDW 
Interpolation inputs window will then appear, which allows you to input the data layer being interpolated and 
customize the interpolation based on your needs. For the ‘Points’ input use the ‘Weather Station’ shape file 
layer. For the ‘Attribute’, select Annual Rainfall from the drop-down selection.  
 
Use the default values for ‘Target Grid’, ‘Distance Coefficient’, ‘Inverse Distance Power’ etc. as they are 
appropriate for the data distribution in this study. And lastly, assign a location to save the output raster ‘Grid’, 
and check the ‘open output file after running algorithm’ check-box. Click ‘Run’. The IDW interpolation tool will 
then output a black and white interpolated raster surface onto the map area. Drag the grid layer bellow the 
point shape file layer and rename it by right-clicking on the raster grid and selecting ‘rename’. The next step 
is to assign a colour ramp to this reclassified raster layer. To do this, right-click on the ‘renamed file’ and select 
‘properties’. Select the ‘Symbology’ tab, and then pick ‘Single band pseudocolor’ in the ‘render type’ drop-
down box.  
 
Then in the ‘Generate new colour map’ area, choose the ‘spectral’ colour ramp, check the ‘invert’ checkbox, 
select the ‘Equal Interval’ mode and 6 classes. Assign a min value and max value, and then click the ‘classify’ 
button. This will create a 6-class colour which needs to be reclassified based on the values of the ‘reclassified 
grid’. After modifying the colour ramp values to reflect the correct range of values from the reclassified grid, 
click ‘apply’ and ‘ok’ and you will now have coloured map of the file. The last step of this mapping process is 
to create a polygon of the lake which will be used as a mask to clip the interpolation surface. 
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Creating Clipping Polygon and Clipping Interpolation Surface 
 
To create a clipping mask for the interpolation raster surface you have to digitize a polygon of the interested 
area boundary and then clip the interpolated surfaces with it, so that the interpolation does not extend onto 
land (which may have very different as concentrations compared to water). In order to do so, a new shapefile 
needs to be created. Under the ‘Layer’ tab, click on ‘Create Layer’ and then select ‘New Shapefile Layer’. 
In the ‘New Shapefile Layer’ window, select the option to create a ‘polygon’ in the ‘type’ field. Then specify 
the correct projection for the shapefile. Seeing that this shapefile is just going to be used to create a clipping 
mask polygon, no ‘new attributes’ need to be assigned. Click 'ok'. A window will then appear which allows you 
to specify a filename and location to save the new shapefile. Call is ‘Clip Polygon’ and save it. You will now 
notice your new polygon shapefile in the list of layers. The next step will be digitizing a polygon of the 
interested area. Right-click on the ‘Clip Polygon’ layer and select the ‘Toggle editing’ button. 
Then click the ‘Add Feature’ button to start creating the polygon. Start digitizing the polygon by clicking on the 
edge of the interested area and following the boundary all around the area. Use as many digitizing points as 
possible to ensure an accurate polygon. Once you have finished digitizing your polygon, right click on the last 
point. A window will appear that will allow you to specify an id for the polygon, assign it a value of ‘1’. Then 
click 'ok'. Now that we have our Area polygon, we can save the edits made to the shapefile and close the 
editor. Click on the ‘current edits’ button and select the ‘save for all layers’ button. Then right-click on the Clip 
Polygon shapefile layer and click on the ‘Toggle editing’ button to stop editing the polygon. 
Now we are ready to clip the ‘Reclassified grid’ using the ‘Clipping Polygon’. To do so, search for the tool ‘Clip 
grid with polygon’ in the processing toolbox and open it. In the ‘clip grid with polygon’ tool window, assign 
the ‘Reclassified Grid’ as the input raster layer and the ‘Clip Polygon’ as the input polygon. Specify an output 
filename ‘Jhunjhanu map’ and click run. You will notice that the reclassified grid is now clipped, but the default 
original greyscale colouring has returned. 
There is a quick way to re-symbolize the clipped raster with the appropriate colour ramp. Right-click on the 
‘reclassified grid’, which still has its intact colour ramp and open the properties menu. Click on the ‘export 
colour map file’ button and save the text file to hard drive. Then re-open the properties menu for the 
‘Jhunjhanu map’ raster, select the ‘style’ tab, and then pick ‘Singleband Pseudocolor’ for the ‘render type’. 
Then click on the ‘load colour map from file button’ and open the saved text file from the earlier step. You will 
now notice that your legend is back to the original format. 
And now the map is complete and ready to be checked for accuracy. When you inspect as concentration point 
values and the interpolated surface value under each point (looking at the legend), you will see that all the 
points fall in the correct interpolated value range area, indicating a good interpolation job. Now that the IDW 
interpolation map is complete. 
 
Exporting the Final Maps 
 
Under the ‘Project’ tab, select “New Print Layout’. Assign a ‘Create Print Layout’ that will be used for the new 
print composer (For example: ‘JHUNJHANU MAP 2000’). Under the ‘Layout’ tab, you can add a number of map 
elements to the print composer including the actual map, a legend, scale bars, etc., depending on the nature 
and purpose of the final map.  
 
Make sure you zoom to the layer extent of the Jhunjhunu map 2000 first before adding it as a map to the print 
composer, text editing for the ‘label’ is done in a text editing box on the right-hand side of the print composer 
window. There is a wide variety of graphics editing tools within this print composer, so feel free to explore and 
play with them before exporting the final map. 
 
The last step of this will be exporting the map and for this there are a number of formats available to export 
the final map as, which including: JPEG file, PDF or as an SVG file. To export the map, click on the ‘Layout’ tab 
and select the ‘Export as Image’ tab. Assign a file name to the exported image like PNG, JPG, JPEG file etc., 
and click save.
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Results 
 

Table 1. Average Rainfall and Rainy days from 2000 to 2021 of Churu district. 
YEAR AVERAGE RAINFALL (mm) AVERAGE RAINY DAYS 

2000 233 13 

2001 369 22 

2002 162 12 

2003 414 23 

2004 296 18 

2005 356 26 

2006 297 18 

2007 405 27 

2008 506 30 

2009 265 18 

2010 650 33 

2011 660 32 

2012 430 22 

2013 493 31 

2014 472 28 

2015 515 31 

2016 465 25 

2017 354 24 

2018 341 22 

2019 468 27 

2020 476 30 

2021 574 32 

5.1 Churu District Average Rainfall Data: 
 
With the help of average rainfall data we can say that Churu district received rainfall between a ranges of 200-
600 mm in last 22 years and only three times the rainfall crosses this range in these years. In the years 2010 
and 2011 the rainfall is more than this range with nearly 650 mm and in the year 2002 rainfall is very low and 
it goes below the range nearly 180 mm. Average rainfall data show a gradual increases in the last years in the 
region. 
In the year 2008, 2010, 2011, 2013, 2015 and 2021, average rainfall received in Churu is near 500mm which is 
an average so that it can be considered as normal rainfall. 
 

 
Figure 1: Churu district average rainfall data 
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Churu district average rainy days: 
 
With the help of data of average rainy days we can say that Churu district rainfall days are between a ranges 
of 15-30 in last 22 years and average rainfall data show a gradual increases in the last years in the region. 
Average rainy days are consistently following an increasing pattern. In last 10 years average rainy days are 
higher than 20 days and crossed 30 days line 6 times. 
 

 
Figure 2: Churu district average rainy days. 

 
Churu Rainfall Distribution 2000: 
 
There were seven weather stations in Churu district in 2000. If we go through the complete rainfall 
distribution data of Churu district for year 2000 as per above rainfall distribution map, we found that in the 
year 2000 rainfall distribution in Churu district is being decreases when going north to south or east to west 
direction of Churu district. Taranagar and Rajgarh blocks get highest rainfall during the whole year and 
Sardarsahar block is on second position. Sujangarh block get lowest rain fall during the whole year. Ratangarh 
and Dungargarh block get second position in lowest rainfall in the region while Churu block get average 
rainfall. 
 

 
Figure 3: Churu district thematic map 2000. 

 
Churu Rainfall Distribution 2010: 
 
In Churu district there were seven weather station in 2010. If we go through the data of complete rainfall 
distribution at each weather station as per above graph, we found that in the year 2010 rainfall distribution in 
weather stations of Churu district is being decreases when going north to south or east to west direction of 
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Churu district. Taranagar and Rajgarh blocks get highest rainfall during the whole year and Sardarsahar block is 
on second position. Sujangarh block get lowest rain fall during the whole year. Ratangarh and Dungargarh block 
get second position in lowest rainfall in the region. Churu block get average rainfall. 
 

 
Figure 4: Churu district thematic map 2010. 

 
Churu Rainfall Distribution 2020: 
 
In Churu district there are eight weather station in 2020 and Bidasar is latest weather station. If we go through 
the complete rainfall distribution data of Churu district for year 2020 as per above rainfall distribution map, 
we found that in the year 2020 rainfall distribution in Churu district is also being decreases when going north 
to south or east to west direction of Churu district. Sardarsahar block get highest rainfall during the whole 
year. Taranagar, Churu and Rajgarh blocks is on second position. Dungargarh and Sujangarh block get lowest 
rain fall during the whole year. Ratangarh and Bidasar block get average rainfall throughout the year. 
 

 
Fig 5: Churu district thematic map 2020 

 
Churu District Average Rainfall Distribution 2000-2021: 
 
In Churu district, 22 years average rainfall data analysis in the thematic map shows that the average rainfall 
of last two decades is more in south-eastern region compare to the north-western region. Bidasar block 
shows highest rainfall in last decades because this weather station established in 2019 and in last 5 years 
rainfall in this block is high. Dungargarh block get lowest rainfall during the two decades in the district. In other 
blocks, in last two decades received rainfall is nearly equal at all stations or not have much difference. 
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Figure 6: Churu district average rainfall from 2000 to 2021 thematic map 

 
Conclusion 
 
In the present study, the analysis of the rainfall data show increasing trend in rainfall amount of Jhunjhunu 
district and rainy days are also show a slow increasing pattern in Jhunjhunu. In the study of twenty years 
rainfall data, we found that South and South-eastern and some part of North region of the Jhunjhunu get 
maximum rainfall and North-eastern and western parts of the Jhunjhunu district get lowest rainfall  
In Jhunjhunu district, rate of ground recharge is less because of low rainfall and high temperature. The 
combined use of surface water, available rainfall and groundwater is essential for better agricultural 
management and irrigation in the area. The analysis helps to understand the rainfall pattern in the Jhunjhunu 
region and to plan the plants for efficiency and water availability in the region. 
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